Como usar a fórmula COL para turbinar seu PROCV - Academia Excel

Este site usa cookies e tecnologias afins que nos ajudam a oferecer uma melhor experiência. Ao clicar no botão "Aceitar" ou continuar sua navegação você concorda com o uso de cookies.

Aceitar
Como usar a fórmula COL para turbinar seu PROCV

Treinos Avançados

Como usar a fórmula COL para turbinar seu PROCV

Academia Excel
Escrito por Academia Excel em julho 17, 2020
10 min de leitura
Junte-se a mais de X pessoas

Entre para nossa lista e receba conteúdos exclusivos e com prioridade

Fala galeraaaa, bora para mais um treino? 😃

Quem nunca precisou dar uma turbina na função PROCV? Seja você usuário iniciante e até mesmo avançado, provavelmente já se deparou com uma situação semelhante.

Em nossa tabela temos os nomes, altura, idade e raça de um grupo de pessoas. Desejamos que ao digitar o nome ele retorne na tabela acima as mesmas informações.

Sabemos que a função PROCV ao ser feita na coluna altura e puxar a fórmula para o lado, as células que contêm a idade e raça, a fórmula não manterá o número índice coluna, para isso, usaremos um truque. 😉

Passo 1: Iremos fazer a função PROCV na célula B2.

Fórmula: =PROCV($A$2;$A$5:$D$18;2;0)

Como dito anteriormente, a fórmula se eu arrastar para o lado, não é realizada a função nas demais colunas, pois o número índice coluna não se altera, teria que realizar manualmente ou fazer a junção de uma outra fórmula.

Note na barra de fórmulas que o número índice coluna continua sendo o 2 e que os resultados na coluna idade e raça, foram os valores referentes a altura.

Usando a função COL

A função coluna retorna o número da coluna de referência da célula fornecida.

Sintaxe: COL([referência])

Usaremos a função COL no lugar do número índice coluna, para que seja dinâmico.

Fórmula: =PROCV($A$2;$A$5:$D$18;COL(B1);0)

A referência usada foi a célula B1, local onde se encontra o título altura, assim quando puxarmos a fórmula para a lateral, ela seguirá as referências para C1 e D1.

Agora sim, ao realizar a função PROCV e precisar puxar as fórmulas, lembre-se desse treino que lhe auxiliará bastante em seu dia a dia no Excel.

E aí, o que achou do treino desse treino? 💪 Comenta aqui embaixo 👇

Opa,

o que você achou dessa aula? Conta pra mim 👇

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

×
Escolha um atendente disponível 👇
×