Como usar a função substituir para remover caracteres especiais de um CPF - Academia Excel

Este site usa cookies e tecnologias afins que nos ajudam a oferecer uma melhor experiência. Ao clicar no botão "Aceitar" ou continuar sua navegação você concorda com o uso de cookies.

Aceitar
Como usar a função substituir para remover caracteres especiais de um CPF

Treinos Intermediários

Como usar a função substituir para remover caracteres especiais de um CPF

Academia Excel
Escrito por Academia Excel em julho 23, 2020
5 min de leitura
Junte-se a mais de X pessoas

Entre para nossa lista e receba conteúdos exclusivos e com prioridade

Faaaaala galera, se liga nesse treino de hoje!

Muitas vezes você pode se deparar com situações semelhantes a essa e perder tempo por falta de conhecimento. Mas fique tranquilo, você está no lugar certo, nossa missão é compartilhar conhecimento e fazer que automatize ao máximo suas rotinas no Excel.

 

Sofrendo pra melhorar sua planilha buscando por vídeos soltos na internet? Que tal conhecer meu treinamento Desfio Excel 7D que te leva do zero ao Dashboard em 7 dias de estudos? Clique aqui para saber mais.

Na tabela abaixo, temos uma lista de números de CPF e precisamos extrair desses números os caracteres inseridos: o ponto e o hífen.

CLIQUE AQUI PARA FAZER O DOWNLOAD DA PLANILHA

Para que isso seja possível, usaremos a FUNÇÃO SUBSTITUIR.

Essa função coloca novo_texto no lugar de texto_antigo em uma cadeia de texto. Use SUBSTITUIR quando quiser substituir texto específico em uma cadeia de texto.

Sintaxe:

SUBSTITUIR(texto, texto_antigo, novo_texto, [núm_da_ocorrência])

A sintaxe da função SUBSTITUIR tem os seguintes argumentos:

Texto: O texto ou a referência a uma célula que contém o texto no qual deseja substituir caracteres.

Texto_antigo: O texto que se deseja substituir.

Novo_texto: O texto pelo qual deseja substituir texto_antigo.

Núm_da_ocorrência: Especifica que ocorrência de texto_antigo se deseja substituir por novo_texto. Se especificar núm_da_ocorrência, apenas aquela ocorrência de texto_antigo será substituída. Caso contrário, cada ocorrência de texto_antigo no texto é alterada para novo_texto. Por estar entre [] esse argumento não é obrigatório para a função funcionar.

Usando a função 

Digite a seguinte fórmula:

=SUBSTITUIR(B3;”.”;””)

A função substituiu na célula B3 (argumento texto) o ponto (argumento texto_antigo) pelo espaço, representado pela “” (argumento novo_texto).

Ótimo isso né, mas e agora desejamos retirar o hífen, como proceder? 

Colocaremos a função substituir no começo da fórmula, vejamos:

=SUBSTITUIR(SUBSTITUIR(B3;”.”;””);“-“;””)

Ao digitar novamente o substituir, a função anterior se tornou o argumento texto, restando os outros argumentos.

O hífen é o argumento_antigo e o espaço é o novo_texto.

Top demais né?  E se for a situação inversa?

Eu ter somente os números e desejo inserir os caracteres? Bora aproveitar e aprender isso também?

Usaremos a FUNÇÃO TEXTO

 A função TEXTO permite que você altere a maneira de exibir um número aplicando formatação a ele com códigos de formatação.

Sintaxe:

=TEXTO(valor que você deseja formatar; “Código de formatação que deseja aplicar”)

Usando a função em nosso exemplo:

=TEXTO(C3;”00.000.000-00″)

O formato usado no exemplo é o formato do CPF, caminho inverso.

E aí o que achou do treino de hoje? Comenta abaixo 

Veja mais treinos sobre funções de texto:

Opa,

o que você achou dessa aula? Conta pra mim 👇

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

×
Escolha um atendente disponível 👇
×