Fala #AE galera! Vini na área 😎

Na dica de Excel de hoje vamos resolver um problema que me incomodava e me atrapalhava demais e tenho certeza de que você já passou por isso (se não passou, vai passar)

VALORES REPETIDOS 😤😤

Existem inúmeras formas de resolver isso dentro do Excel, já falamos de algumas delas, como REMOVER DUPLICATAS e FORMATAÇÃO CONDICIONAL para marcar os valores repetidos. Mas a dica de hoje é para nossos #veteranos que não se contentam com as dicas básicas e sempre querem mais 😎

Remover duplicatas resolve mas você sempre vai ter que refazer essa ação de tempos em tempos.

Utilizar a formatação condicional mesma coisa. Você vai ter que utilizar o recurso de remover duplicatas da mesma forma…

Por isso, meus amigos, hoje você vai aprender uma dica #AVANÇADA para resolver isso.

Afinal, COMO IMPOSSIBILITAR VALORES REPETIDOS?

Veja o vídeo abaixo e abaixo dele tem o tutorial escrito 😉

Para fazer isso utilizaremos a função CONT.SE com o recurso de VALIDAÇÃO DE DADOS.

Para quem não sabe, a função CONT.SE faz a contagem de valores seguindo um ou mais critérios.

O recurso VALIDAÇÃO DE DADOS valida os dados 😅 ou seja, testa se o valor digitado na célula está seguindo os critérios definidos para ela.

O segredo dessa união é contar quantas vezes foi digitado o texto, se for 0 ou 1, está OK, se forem 2 ou mais a validação de dados vai bloquear o usuário 🚫

Antes de colocar a mão na massa, baixe aqui o arquivo que estou utilizando no vídeo 📥

Vamos ao passo a passo!

1 – Na célula D7 vamos fazer uma função CONT.SE para contar quantas vezes, no intervalo selecionado, repete-se o nome da célula ao lado.

A CONT.SE:

=CONT.SE(intervalo;critérios)

intervalo: aonde estão lançados os valores que você quer contar?

critérios: qual/quais valores você quer contar dentro do intervalo?

=CONT.SE($C$7:$C$12;C7)

Observe que o intervalo eu deixei travado (note os cifrões antes das colunas e linhas). Agora você pode arrastar a fórmula até o último nome digitado, assim aparecerá o número de quantas vezes o nome ao lado se repete na lista 😉

2 Copie a fórmula feita anteriormente (somente da primeira célula, D7).

3 – Vamos aplicar a validação de dados! Menu DADOS – VALIDAÇÃO DE DADOS

A validação de dados entende duas coisas (lembre-se disso): VERDADEIRO ou FALSO. Se for verdadeiro ela vai permitir, se falso ela bloqueia a ação do usuário.

Sabendo disso, vamos prosseguir:

4 – Selecione a permitir – personalizado. Essa opção permite que seja inserida uma fórmula na validação de dados 😉

5 – Cole a fórmula que você copiou no passo 2 ☝

Acabou?!

Não! Como disse, a validação de dados só entende duas coisas, VERDADEIRO ou FALSO. Essa fórmula colada não vai retornar isso (como vimos, ela retorna o número de vezes que o nome ao lado se repete no intervalo).

Mas como fazer ela retornar VERDADEIRO ou FALSO?

Simples, aplicando um teste a ela 😄

Vamos testar se o valor retornado por ela é igual a 1. Se for, ela retornará VERDADEIRO, caso contrário, FALSO. Assim:

=CONT.SE($C$7:$C$12;C7)=1

6 Então o último passo é, no final da sua fórmula (ainda dentro da validação de dados), inserir o =1, dar OK e arrastar a validação para as demais células.

Faça o teste, tente digitar valores duplicados e veja a mágica do Excel.

Caso não tenha entendido ou por algum motivo não deu certo, deixa seu comentário aqui embaixo que te ajudo 💪

Ah, e se conseguiu, deixa o comentário também! Vai ser bom demais saber disso!

DESAFIO EXCEL 7D

DASHBOARDS PROFISSIONAIS
EM 7 DIAS

OU SEU DINHEIRO DE VOLTA!

Crie sua conta :)

Na próxima tela você irá completar seu cadastro e transformar seu negócio.

Precisa de ajuda?
💬 Precisa de ajuda?
Olá 👋🏽
Como podemos te ajudar?