Como fazer mágica utilizando as funções de Data - Academia Excel

Este site usa cookies e tecnologias afins que nos ajudam a oferecer uma melhor experiência. Ao clicar no botão "Aceitar" ou continuar sua navegação você concorda com o uso de cookies.

Aceitar
Como fazer mágica utilizando as funções de Data

Treinos Avançados

Como fazer mágica utilizando as funções de Data

Academia Excel
Escrito por Academia Excel em outubro 28, 2021
10 min de leitura
Junte-se a mais de X pessoas

Entre para nossa lista e receba conteúdos exclusivos e com prioridade

Fala galera! Bora para mais um treino?

Hoje iremos ver como as funções de data, lhe ajudarão a criar relatórios incríveis para sua planilhas!

Nós iremos aprender a criar um fluxo de caixa diário e ele será dinâmico, a partir do ano e mês selecionado.

Primeiro ponto a se observar é o formato dos dia da tabela, eles estão no formato geral.

Para facilitar o uso da função SOMASES onde iremos gerar os relatórios, iremos alterar esse formato de data.

Digite a  data 01/01/2019.

Altere esse formato, para que apareça somente os dias:

Na Página Inicial clique em mais formatos de número…

Escolha a opção Personalizado e digite dd, que corresponderá dois dígitos para os dias.

Arraste para baixo a formatação. Desejamos que esses dias se alterem de acordo com o mês escolhido, ao digitar fevereiro, ele se altere para as datas de fevereiro e assim por diante.

Para isso, iremos utilizar a função Data, referenciando o dia, mês e ano. Para que os meses sejam dinâmicos, precisamos inserir em algum lugar essa informação.

Digite em uma guia auxiliar uma tabela com os nomes dos meses e sua ID.

Vamos utilizar a função PROCV, para que ao escolher o mês desejado, traga essa ID automaticamente.

Fórmula: =PROCV(O5

O valor procurado será a célula O5, onde estão os meses.

Fórmula: =PROCV(O5;Tabela11;

A matriz tabela será a tabelinha que criamos nos dados auxiliares, onde estão os meses e sua ID.

Fórmula: =PROCV(O5;Tabela11;2;0)

O número índice coluna será o 2, onde estão as ID dos meses na matriz tabela e utilizaremos o número 0, para correspondência exata.

Para automatizar o resultado e ele retorne o dia, mês e ano exato, iremos utilizar a função DATA

Fórmula: =DATA(O4;O6;1)

Referenciamos o ano, mês e o dia digitamos 1.

Para os próximos dias, referencie a célula acima e some mais 1.

Fórmula: =B4+1

Arraste até o final da tabela, o dia 15. Repita esse processo para a tabela ao lado.

Fórmula: =B18+1

Repita o processo referenciando a célula acima para o restante da tabela.

Fórmula: =H4+1

Sabemos que os meses não tem a mesma quantidade de dias, alguns 30, outros 31 e fevereiro 28 ou 29 dependendo do ano.

Sendo assim, precisamos realizar uma fórmula que corrija e pare no último dia do mês correspondente.

Vamos utilizar a função Se e a função FIMMÊS

Fórmula: =SE(H16<FIMMÊS(H16;0);H16+1;””)

Se a célula acima for menor que o fim do mês dessa mesma célula, ela somará mais um dia, se não for, ela retornará vazia. Arraste essa fórmula até a linha 5.

Note que as células abaixo tivemos um erro, para isso iremos tratar com a função SEERRO

Fórmula: =SEERRO(SE(H4<FIMMÊS(H4;0);H4+1;””);””)

E aí, o que achou do treino de hoje? Comente abaixo:

 

 

 

 

Opa,

o que você achou dessa aula? Conta pra mim 👇

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

×
Escolha um atendente disponível 👇
×