Como usar a função ÍNDICE + CORRESP com mais de uma condição - Academia Excel

Este site usa cookies e tecnologias afins que nos ajudam a oferecer uma melhor experiência. Ao clicar no botão "Aceitar" ou continuar sua navegação você concorda com o uso de cookies.

Aceitar
Como usar a função ÍNDICE + CORRESP com mais de uma condição

Treinos Avançados

Como usar a função ÍNDICE + CORRESP com mais de uma condição

Academia Excel
Escrito por Academia Excel em julho 8, 2020
10 min de leitura
Junte-se a mais de X pessoas

Entre para nossa lista e receba conteúdos exclusivos e com prioridade

Fala galera, se você já segue a Academia Excel, sabe que as funções ÍNDICE+CORRESP é uma evolução da função PROCV

E hoje iremos aprender como utilizar essas funções para retornar duas ou mais soluções, vejamos 😉

Baixe a planilha aqui

Vamos ao passo a passo por escrito:

A planilha usada em nosso vídeo, possui a seguinte estrutura:

Vendedor, Dia da semana e Loja. Na tabela ao lado, temos os vendedores e dia da semana, onde desejamos que ao selecionar o vendedor e o dia da semana, ele retorne em qual loja o mesmo estará.

Na célula H4, usaremos as seguintes funções:

=ÍNDICE(B4:D12;CORRESP(F4&G4;B4:B12&C4:C12;0);3)

Feito isso, para confirmar a ação, pressione as seguintes teclas: CTRL+SHIFT+ENTER se pressionar somente a tecla ENTER a função não dará certo, por se tratar de matrizes.

Entendo as funções…

FUNÇÃO ÍNDICE: A função ÍNDICE retorna um valor ou a referência a um valor de dentro de uma tabela ou intervalo. Também é conhecida como uma função auxiliar.

Sintaxe: ÍNDICE(matriz; núm_linha; [núm_coluna])

FUNÇÃO CORRESP: A função Corresp procura um item especificado em um intervalo de células e retorna à posição relativa desse item no intervalo, é uma função auxiliar.

Sintaxe: =CORRESP(valor_procurado, matriz_procurada, [tipo_correspondência])

Unindo as funções 😇

Observe que ao digitarmos a fórmula: =ÍNDICE(B4:D12 é referente a matriz, ou seja o intervalo em nossa tabela onde está referenciado a nossa base de dados.

Logo após a matriz, o próximo critério da função ÍNDICE é núm_linha, que assumiu a função CORRESP.

A função CORRESP utilizada contou com o valor_ procurado as células F4&G4. Por que usamos duas referência e o símbolo &? Porque nesse caso desejamos unir as informações das duas células: F4 onde será selecionado o nome do vendedor e G4 onde será selecionado o dia da semana. E o símbolo &? Esse símbolo é capaz de CONCATENAR ou seja unir as informações.

Continuando a sintaxe do CORRESP, temos o segundo argumento: B4:B12&C4:C12 referente a matriz, que nesse caso também foi selecionada o intervalo dos vendedores e logo após o intervalo do dia da semana, contando também com a função CONCATENAR através do símbolo &.

[tipo_correspondência]): para finalizar nossa fórmula, digitamos o número 0 que corresponde a um valor exato.

Feito a função CORRESP a fórmula retorna para finalizarmos a função ÍNDICE. Colocaremos o número 3, mas por que 3? Porque na função ÍNDICE o último argumento é [núm_coluna], que em nossa tabela de dados é referente a loja, informação no qual será retornada em nossa busca 😎

Feita as funções, agora toda vez que eu selecionar um vendedor e o dia da semana, ele retornará a loja do mesmo 😎

Você deve ter notado que as células de vendedor e dia da semana, estão com uma flechinha disponível para selecionar esses dados? Fique tranquilo, em breve lançaremos um post sobre esse poderoso recurso, chamado Validação de dados 👊

E aí, o que achou do treino de hoje? 💪Comenta aqui embaixo👇

Opa,

o que você achou dessa aula? Conta pra mim 👇

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

2 Replies to “Como usar a função ÍNDICE + CORRESP com mais de uma condição”

roberto

Queria saber como fazer pra trazer mais de um resultado nessa fórmula. Vou tirar minha dúvida adaptando para o exemplo usado nesse artigo.

Digamos que na minha planilha cada vendedor trabalha em duas lojas por dia. A planilha tem o dobro de linhas dessa do artigo, porque pra cada vendedor e pra cada dia da semana teria duas linhas de loja, por exemplo:
VENDEDOR DIA DA SEMANA LOJA
joão dom centro
joão dom bairro floresta
marcos dom bairro floresta
marcos dom centro…

teria como trazer na mesma célula H4 as duas lojas concatenadas ? tipo: trazer na célula H4 “centro e bairro floresta” para joão no domingo ?

Automatizando uma planilha de pagamentos com ÍNDICE e CONT.SE – Academia Excel

[…] Como usar a função ÍNDICE + CORRESP com mais de uma condição […]

DESAFIO EXCEL 7D

DASHBOARDS PROFISSIONAIS
EM 7 DIAS

OU SEU DINHEIRO DE VOLTA!

Crie sua conta :)

Na próxima tela você irá completar seu cadastro e transformar seu negócio.

×
Escolha um atendente disponível 👇
×