Erro no PROCV Depois dessa sacada, nunca mais! - Academia Excel

Este site usa cookies e tecnologias afins que nos ajudam a oferecer uma melhor experiência. Ao clicar no botão "Aceitar" ou continuar sua navegação você concorda com o uso de cookies.

Aceitar
Erro no PROCV Depois dessa sacada, nunca mais!

Treinos Avançados

Erro no PROCV Depois dessa sacada, nunca mais!

Academia Excel
Escrito por Academia Excel em agosto 13, 2020
10 min de leitura
Junte-se a mais de X pessoas

Entre para nossa lista e receba conteúdos exclusivos e com prioridade

Faaala galera, prontos para mais um treino?

O treino de hoje iremos corrigir o pior erro existente no PROCV.

Na tabela de exemplo temos os nomes, matrículas, setores e salários de colaboradores.

Primeiro passo: fazer a função PROCV

=PROCV(G4;B3:E11;4;0)

O resultado encontrado foi o salário referente ao colaborador Luiz.

Até aí tudo normalizado. Porém muitas das vezes é necessário alterar essa matriz tabela, inserir uma coluna por exemplo.

Ao realizar essa inserção, o resultado será alterado para setor, pois agora a matriz tabela passou a ter uma coluna a mais, logo o número índice coluna foi mantido 4, retornando assim o setor e não o valor do salário como necessário.

O que fazer para que essa coluna se altere automaticamente, quando a matriz tabela for modificada?

Usaremos a função COL, no lugar do número índice coluna.

Função COL

A função coluna retorna o número da coluna do referência de célula fornecido.

Sintaxe: COL([referência])

Insira a seguinte fórmula no lugar do número índice coluna

=PROCV(G4;B3:E11;COL(E3);0)

Observe na imagem acima que ao realizar a fórmula referenciando E3, a tabela selecionada em vermelho busca a partir da coluna B, fazendo com que a fórmula não retorne o salário. Nesse caso teremos que modificar a fórmula.

Vamos inserir o -1, para que ele não conte com a primeira coluna, a letra A.

=PROCV(G4;B3:E11;COL(E3)-1;0)

Agora podemos inserir colunas no meio da tabela se necessário, que a fórmula não irá ser alterada.

Porém se a coluna for inserida no início da tabela, ainda assim dará erro.

Iremos alterar a fórmula, no lugar do -1, insira outra função COL referenciando a primeira coluna da matriz tabela, a célula B3. Somaremos com o número 1, pois se ele estiver na coluna 9 por exemplo, tem que retirar 9 e não 10.

=PROCV(G4;B3:E11;COL(E3)-COL(B3)+1;0)

Independente de onde for inserida ou excluída a coluna, o resultado não será alterado.

E aí, o que achou do treino de hoje? Comente abaixo:

Opa,

o que você achou dessa aula? Conta pra mim 👇

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

×
Escolha um atendente disponível 👇
×