PROCV com LIN - Academia Excel

Este site usa cookies e tecnologias afins que nos ajudam a oferecer uma melhor experiência. Ao clicar no botão "Aceitar" ou continuar sua navegação você concorda com o uso de cookies.

Aceitar
PROCV com LIN

Treinos Avançados

PROCV com LIN

Academia Excel
Escrito por Academia Excel em julho 31, 2020
10 min de leitura
Junte-se a mais de X pessoas

Entre para nossa lista e receba conteúdos exclusivos e com prioridade

Fala galeraaa prontos para mais um treino?

A função PROCV permite fazer procuras incríveis em nossas planilhas e associada a outras fórmulas conseguimos turbinar ainda mais. Se você é um acadêmico tem notado isso nos post´s anteriores.

Hoje iremos unir a função PROCV com a LIN, bora lá =)

Nossa tabela contem alguns dados de pessoas e iremos realizar a função PROCV na tabela ao lado. Os dados estão dispostos na vertical e desejamos puxar essa fórmula sem ter que fazer essa alteração manualmente, vejamos:

Passo 1: Realizar a função PROCV.

Fórmula: PROCV(H3;B3:E16;2;0)

Passo 2: para arrastar as fórmula para baixo, iremos travar algumas células: PROCV($H$3;$B$3:$E$16;2;0)

Mesmo travando essas células, ao arrastar as fórmulas os outros dados não se alteram, pois o número índice coluna que é o 2, varia de acordo com cada item buscado (altura, idade e raça).

Para que se torne dinâmico, iremos substituir o número índice coluna pela função LIN.

FUNÇÃO LIN

Retorna o número da linha de uma referência.

Sintaxe: LIN([referência])

Passo 3: substitua o número índice coluna pela função LIN

=PROCV($H$3;$B$3;$E$16;LIN(A2);0)

Inserimos a função LIN referenciando a célula A2, pois assim ele irá retornar o número 2 e esse intervalo estando “solto”, ou seja, sem o recurso de travar células, ao arrastar a fórmula para baixo, mudará automaticamente.

Dica bônus 🤩

Para que não tenha que digitar toda vez que fizer a procura o nome do usuário, iremos realizar uma lista suspensa.

Passo 1: Clique na célula H3, onde ficará essa lista.

Passo 2: Clique na guia dados, validação de dados.

Em permitir, clique na flechinha e escolha a opção: lista.

Em fonte, clique na flechinha para selecionar a fonte de dados, o intervalo que contenha as suas informações, em nosso exemplo será os nomes.

Confirme clicando no Ok. Agora podemos selecionar os nomes para a busca.

E aí, o que achou do treino de hoje? Comenta aqui embaixo:

Opa,

o que você achou dessa aula? Conta pra mim 👇

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

DESAFIO EXCEL 7D

DASHBOARDS PROFISSIONAIS
EM 7 DIAS

OU SEU DINHEIRO DE VOLTA!

Crie sua conta :)

Na próxima tela você irá completar seu cadastro e transformar seu negócio.

×
Escolha um atendente disponível 👇
×