Faaala galera, bora para mais um treino?

Hoje iremos ver como realizar um PROCV para números repetidos.

Fizemos um post onde realizamos um ranking por nota e quando a nota era igual, a função não conseguia criar o ranking. Se você não viu esse post, CLIQUE AQUI.

Em nosso exemplo usaremos uma planilha com salário

Passo 1: Utilizar a função MAIOR.

Na coluna de salários, faça a função MAIOR selecionando todo o intervalo dos salários e o valor K será a referência J4, o número 1.

Fórmula: =MAIOR($E$4:$E$11;J4)

Passo 2: Fazer a função PROCV para encontrar os nomes

Após criar o ranking dos salários, usamos a função PROCV para exibir os nomes das pessoas com maior salário.

Fórmula: =PROCV(K4;$E$4:$F$11;2;0)

Quando ele puxa os nomes, os valores duplicados repetem os nomes. Note que o nome Renato e Carla aparecem duas vezes na listagem.

Carla e Stefanie possuem o mesmo salário, precisamos corrigir para que se altere o nome.

Passo 3: Utilizar a função CONT.SE para encontrar valores repetidos

Crie uma coluna auxiliar e nomeie como repetidos. Em seguida realize a função

Fórmula: =CONT.SE($E$4:E4;E4)

A função faz a contagem e os números que são repetidos, retorna o valor 2, que é o caso dos dois últimos, Paulo Stefanie.

Passo 4: Concatenar alguns valores para criar o ranking

Crie outra coluna auxiliar e concatene as fórmulas.

Fórmula: =E4-(F4*0,0001)

Subtraímos o salário pela multiplicação do valor repetido por 0,0001. Para que fique exibido mais casas decimais, aumente na página inicial, conforme imagem acima. Fazendo essa multiplicação por milésimo de centavos, o ranking ficará correto.

Passo 5: Insira uma coluna auxiliar para realizar a função MAIOR

Insira uma coluna onde realizamos a função PROCV, apague essa função e refaça a estrutura.

Fórmula: =MAIOR($G$4:$G$11;J4)

Passo 6: Faça a função PROCV para exibir os nomes

Fórmula: =PROCV(L4;$G$4:$H$11;2;0)

Passo 7: Faça a função PROCV para exibir os salários

Fórmula: =PROCV(K4;$B$4:$E$11;4;0)

Oculte as colunas auxiliares. Selecione as colunas, clique com o botão direito do mouse, opção Ocultar.

Resultado:

Os salários repetidos agora alteram-se os nomes também.

E aí, o que achou do treino de hoje? Comente abaixo:

 

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.