Faaalaa galera, prontos para mais um treino?

Esse post é sobre uma dúvida que surgiu de um dos nossos acadêmicos, após postarmos um vídeo que fazia um ranking por nota, se você ainda não viu esse vídeo, CLIQUE AQUI.

Nesse post, iremos fazer um ranking, mesmo que os valores estejam duplicados.

Nosso exemplo não será com as notas e sim com salários.

Passo 1: Utilizando a função MAIOR

Fórmula: =MAIOR($E$4:$E$11;J4)

Faça a função maior com o intervalo dos salários e com o critério K a referência J4.

Passo 2: Utilize a função PROCV para exibir o nome da pessoa com maior salário.

Fórmula: =PROCV(K4;$E$4:$F$11;2;0)

Observe que o nome da Carla foi exibido duas vezes, por conta do valor do salário. E o salário com esse valor, temos também a Stefanie.

Passo 3: Crie uma coluna auxiliar para contar os valores repetidos.

Para corrigir o ranking, iremos fazer a função CONT.SE para exibir quantas vezes o número foi repetido.

Fórmula: =CONT.SE($E$4:E4;E4)

Note que o Paulo e Stefanie deram resultado 2, pois possuem salários iguais. Paulo tem o mesmo salário que Renato e Stefanie o mesmo salário da Carla.

Passo 4: Crie uma coluna auxiliar para concatenar alguns valores.

Fórmula: =E4-(F4*0,0001)

O valor do salário (E4) será subtraído pelo valor encontrado repetido (F4) que foi multiplicado por 0,0001. Aumente as casas decimais para exibir os valores. Multiplicamos por 1 centésimo de centavos para exibir as casas demais, assim os valores não ficam repetidos.

Passo 5: Crie uma coluna auxiliar para a função MAIOR.

Apague os dados feitos, vamos alterar essa estrutura.

Na coluna Auxiliar, faça a função MAIOR

Fórmula: =MAIOR($G$4:$G$11;J4)

Passo 6: Faça a função PROCV para exibir os nomes.

Fórmula: =PROCV(L4;$G$4:$H$11;2;0)

Passo 7: Faça um PROCV para os salários.

Fórmula: =PROCV(K4;$B$4:$E$11;4;0)

Passo 8: Oculte as colunas auxiliares.

Selecione as colunas em azul, clique com o botão direito do mouse, ocultar.

Repita o processo para a outra coluna em azul.

Mesmo com salários repetidos, os nomes serão exibidos em ordem de ranking.

E aí, o que achou do treino de hoje? Comente abaixo:

 

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.