Fala acadêmicos! Prontos para mais um treino?

Hoje iremos ver como criar uma validação de dados, que permita apenas números únicos

Curtindo nosso conteúdo?
Que tal se aperfeiçoar fazendo parte de nosso time de alunos?💚
Saiba mais clicando nesse link

Em nossa planilha, temos uma coluna que serão alimentadas as notas fiscais.

Desejamos que seja preenchido, apenas números únicos, portanto, textos e números repetidos não serão aceitos.

Passo 1: Criar uma fórmula que conte se o número é único

Iremos utilizar a função Cont.se

Fórmula: =CONT.SE($C$3:C3;C3)

Passo 2: Criar uma fórmula que garanta que a informação digitada seja número.

Para isso iremos utilizar a função E, que garante que dois argumentos sejam verdadeiros dentro da função.

Antes da função cont.se, iremos inserir a função E.

O cont.se será o primeiro teste lógico da função, se essa contagem for igual a 1, significa que é a primeira vez que o número aparece.

O segundo teste lógico irá testar se a célula é um número, para isso iremos utilizar a função ÉNUM.

Podemos digitar ou buscar essa informação na guia Fórmulas, mais funções, informações, ÉNÚM

Abrirá uma janela onde devo digitar a célula que será testada, nesse caso a célula C3.

Feche o parênteses da função ÉNUM e da função E

Fórmula: =E(CONT.SE($C$3:C3;C3)=1;ÉNÚM(C3))

Para as células que possuem o número único e que realmente são números, são testadas como verdadeiro. As células com resultado falso, possui valor duplicado ou texto.

Selecione a coluna de notas fiscais,  copie a fórmula e cole na validação de dados.

Clique em Dados, validação de dados

Escolha o formato personalizado e cole a fórmula no espaço destinado.

Confirme clicando em ok.

E aí, o que achou do treino de hoje? Comente abaixo:

 

 

DESAFIO EXCEL 7D

DASHBOARDS PROFISSIONAIS
EM 7 DIAS

OU SEU DINHEIRO DE VOLTA!

Crie sua conta :)

Na próxima tela você irá completar seu cadastro e transformar seu negócio.

Precisa de ajuda?
💬 Precisa de ajuda?
Olá 👋🏽
Como podemos te ajudar?