PROCV ou ÍNDICE CORRESP? Saiba qual utilizar - Academia Excel

Este site usa cookies e tecnologias afins que nos ajudam a oferecer uma melhor experiência. Ao clicar no botão "Aceitar" ou continuar sua navegação você concorda com o uso de cookies.

Aceitar
PROCV ou ÍNDICE CORRESP? Saiba qual utilizar

Treinos Intermediários

PROCV ou ÍNDICE CORRESP? Saiba qual utilizar

Academia Excel
Escrito por Academia Excel em setembro 20, 2021
5 min de leitura
Junte-se a mais de X pessoas

Entre para nossa lista e receba conteúdos exclusivos e com prioridade

Faaaala acadêmicos! Prontos para mais um treino?

Muitos usuários fiquem em dúvida quando escolher a função PROCV e quando escolher as funções ÍNDICE e CORRESP. Nesse post esclareceremos todas suas dúvidas 😉

 

Curtindo nosso conteúdo?
Que tal se aperfeiçoar fazendo parte de nosso time de alunos?💚
Saiba mais clicando nesse link

Nossa planilha contêm os nomes dos vendedores e os valores de suas vendas.

Iremos iniciar utilizando a função PROCV. Temos alguns posts sobre essa função, caso não tenha visto ainda, clique abaixo:

A função PROCV realiza a procura na vertical.

Fórmula: =PROCV(G3;B3:C7;2;FALSO)

Função ÍNDICE+CORRESP

Não iremos detalhar a sintaxe de cada função, temos um post sobre isso:

Desejamos encontrar o valor da venda de acordo com o nome do vendedor digitado, porém o mês correspondente a pesquisa, queremos sempre alterar, não ser fixo.

A função PROCV por si só não consegue realizar, mas as funções ÍNDICE+CORRESP sim

Função ÍNDICE

Fórmula: =ÍNDICE(Tabela2[[JAN]:[DEZ]];5;12)

FUNÇÃO CORRESP

Fórmula: =CORRESP(B11;Tabela2[NOME];0)

O resultado 5, significa que a Rita está na linha 5.

Se alterarmos para Rodrigo, o resultado será 2:

Podemos utilizar a função CORRESP para colunas, nesse caso retornará a localização dos meses.

Fórmula: =CORRESP(C10;Tabela2[[#Cabeçalhos];[JAN]:[DEZ]];0)

Basta copiar as funções e substituir pelas linhas e colunas da ÍNDICE

Fórmula: =ÍNDICE(Tabela2[[JAN]:[DEZ]];CORRESP(B11;Tabela2[NOME];0);CORRESP(C10;Tabela2[[#Cabeçalhos];[JAN]:[DEZ]];0))

Considerações finais

Qual função devo utilizar?

Use a que mais tenha facilidade, mas se atente ao resultado final, muitas vezes somente uma função não irá te atender e terá que unir a outras funções.

E aí, o que achou do treino de hoje? Comente abaixo:

Opa,

o que você achou dessa aula? Conta pra mim 👇

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

×
Escolha um atendente disponível 👇
×