Utilizando o Somases para automatizar um fluxo de caixa - Academia Excel

Este site usa cookies e tecnologias afins que nos ajudam a oferecer uma melhor experiência. Ao clicar no botão "Aceitar" ou continuar sua navegação você concorda com o uso de cookies.

Aceitar
Utilizando o Somases para automatizar um fluxo de caixa

Treinos Intermediários

Utilizando o Somases para automatizar um fluxo de caixa

Academia Excel
Escrito por Academia Excel em janeiro 20, 2022
5 min de leitura
Junte-se a mais de X pessoas

Entre para nossa lista e receba conteúdos exclusivos e com prioridade

Fala acadêmicos, bora para mais um treino?

Ontem vimos como criar um fluxo de caixa diário e dinâmico a partir do mês e ano selecionado, se você ainda não viu esse post, clique no link abaixo:

E hoje iremos gerar o relatório, automatizando esse fluxo de caixa, utilizando a função Somases

 

Os dados a serem utilizados para gerar o fluxo de caixa diário, estão na guia de Entrada.

Iniciando a função

Na guia fluxo de caixa diário, na coluna de entrada, célula D4, inicie a função.

O primeiro argumento da função SOMASES é o intervalo da soma, coluna no qual estão as informações que irão somar de acordo com o critério que precisamos.

Como desejamos somar os valores de entrada, iremos clicar na guia de lançamentos e selecionar essa coluna.

Fórmula: =SOMASES(Tabela1[Valor]

O próximo argumento será o intervalo de critério, que será a coluna de data.

Fórmula: =SOMASES(Tabela1[Valor];Tabela1[Data]

O critério da data, está na guia fluxo de caixa diário, o dia que fizemos a função no post anterior.

Fórmula: =SOMASES(Tabela1[Valor];Tabela1[Data];’FC Diário’!B4

Agora precisamos informar para o Excel, que desejamos somar as entradas dessa data, nosso segundo intervalo de critério será a coluna onde está essa informação, se o valor será de Entrada ou Saída.

Fórmula: =SOMASES(Tabela1[Valor];Tabela1[Data];’FC Diário’!B4;Tabela1[Tipo]

E o critério2 será Entrada

Antes de pressionarmos a tecla enter, iremos iniciar os “travamentos” das células.

Vamos travar a célula B4, para que ela altere somente a coluna. A célula D3 para travar somente a linha e os títulos da tabela que está na guia de lançamentos.

Fórmula: =SOMASES(Tabela1[[Valor]:[Valor]];Tabela1[[Tipo]:[Tipo]];’FC Diário’!D$3;Tabela1[[Data]:[Data]];$B4)

Arraste a fórmula para baixo e para o lado, para calcular as demais entradas e saídas.

Calculando o Saldo Inicial

A princípio iremos referenciar a célula N8.

Calculando o Saldo Final

O saldo final será o valor inserido no saldo inicial, somando as entradas e subtraindo as saídas.

Fórmula: =C4+D4-E4

O saldo inicial do dia 02, será sempre o saldo final do dia anterior.

Fórmula: =F4

Arraste essa fórmula para baixo.

Agora precisamos fazer as mesmas fórmulas para a tabela ao lado. Copie a fórmula realizada nas Entradas.

Altere somente a referência B4 para H4 (que são os dias)

Fórmula: =SOMASES(Tabela1[[Valor]:[Valor]];Tabela1[[Tipo]:[Tipo]];’FC Diário’!J$3;Tabela1[[Data]:[Data]];$H4)

Repita o mesmo processo com a coluna de Saídas.

Fórmula: =SOMASES(Tabela1[[Valor]:[Valor]];Tabela1[[Tipo]:[Tipo]];’FC Diário’!K$3;Tabela1[[Data]:[Data]];$H4)

O saldo inicial do dia 16, será o saldo final do dia 15.

Fórmula: =F18

E o saldo final é a mesma, copie e cole, alterando as referências.

Fórmula: =I4+J4-K4

O saldo inicial do dia 17, será o saldo final do dia 16.

Fórmula: =L4

Precisamos corrigir a fórmula, quando ocorrer a mudança de meses, para acompanhar os dias.

Para isso, iremos utilizar a função SE

Fórmula: =SE(H17=””;””;L16)

Realizamos a função do dia 29, pois se a data acima estiver vazia, que retorne vazio, caso contrário retorne o saldo final doa dia 28, presente na célula L16.

Arraste a fórmula para baixo. Replique a mesma lógica para as demais colunas (entradas, saídas e saldo final).

Fórmula Entrada

Fórmula: =SE(H17=””;””;SOMASES(Tabela1[[Valor]:[Valor]];Tabela1[[Tipo]:[Tipo]];’FC Diário’!J$3;Tabela1[[Data]:[Data]];$H17))

Fórmula Saída

Fórmula: =SE(H17=””;””;SOMASES(Tabela1[[Valor]:[Valor]];Tabela1[[Tipo]:[Tipo]];’FC Diário’!K$3;Tabela1[[Data]:[Data]];$H17))

Fórmula Saldo Final

Fórmula: =SE(H17=””;””;I17+J17-K17)

 

Opa,

o que você achou dessa aula? Conta pra mim 👇

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

×
Escolha um atendente disponível 👇
×