Como impedir valores repetidos - Academia Excel

Este site usa cookies e tecnologias afins que nos ajudam a oferecer uma melhor experiência. Ao clicar no botão "Aceitar" ou continuar sua navegação você concorda com o uso de cookies.

Aceitar
Como impedir valores repetidos

Treinos Intermediários

Como impedir valores repetidos

Academia Excel
Escrito por Academia Excel em janeiro 26, 2021
Junte-se a mais de X pessoas

Entre para nossa lista e receba conteúdos exclusivos e com prioridade

Faala galera, bora para mais um treino?

O treino de hoje veremos como impedir que os usuários insiram dados repetidos.

Para isso usaremos o recurso de VALIDAÇÃO DE DADOS personalizados com uma fórmula. Antes de iniciarmos, vamos conhecer rapidamente a função CONT.SE

Baixe a planilha da aula para me acompanhar

Infográficos

Acompanhamento valores repetidos

Usamos como exemplo o nome Ana e Pedro repetidos. Precisamos usar uma função que conte quantas vezes é utilizado o nome de cada pessoa.

Função Cont.se

 Conta o número de células que atendem a um critério.

Sintaxe: Cont.se(intervalo;critério)

Usamos a função com o intervalo C5:C14, onde travamos esse intervalo. O critério utilizado será a célula C5, onde está digitado o nome Ana. Logo a resposta foi 3, pois é a quantidade de vezes que aparece esse nome.

Arrastando a fórmula para baixo, podemos ver a quantidade de cada nome.

Aplicando a validação de dados

Selecione o intervalo dos nomes e fórmulas e pressione em seu teclado a tecla delete para apagar.

Clique na célula C5, Vá até o menu dados e escolha a opção validação de dados.

Em configurações existem vários critérios de validação. Clique na flechinha e escolha o modelo personalizado.

Em fórmula usaremos a função Cont.se junto com uma lógica.

Fórmula: =CONT.SE($C$5:$C$14;C5)<=1

Usamos a função como no exemplo anterior, porém para que ela não conte apenas os nomes, usamos a lógica para que a resposta dessa contagem seja menor ou igual ao número 1. Isso significa que se o nome encontrado na contagem for menor e igual, ele aceite esse nome. Caso ele conte maior, não será permitido.

Iremos personalizar também um alerta de erro para o usuário, para que apareça uma mensagem.

Ainda na janela da validação de dados, clique na aba alerta de erro e digite a mensagem: Valor repetido

Resultado:

E aí, o que achou do treino de hoje? Comente abaixo:

Opa,

o que você achou dessa aula? Conta pra mim 👇

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

×
Escolha um atendente disponível 👇
×