Truque no PROCV para mudar coluna automaticamente – Academia Excel

Este site usa cookies e tecnologias afins que nos ajudam a oferecer uma melhor experiência. Ao clicar no botão "Aceitar" ou continuar sua navegação você concorda com o uso de cookies.

Aceitar
Truque no PROCV para mudar coluna automaticamente

Treinos Especialistas

Truque no PROCV para mudar coluna automaticamente

Academia Excel
Escrito por Academia Excel em dezembro 8, 2020
Junte-se a mais de X pessoas

Entre para nossa lista e receba conteúdos exclusivos e com prioridade

Fala acadêmicos, prontos para mais um treino?

Hoje veremos como alterar a coluna do PROCV automaticamente, sem mudar a fórmula a cada escolha.

Nossa planilha contêm Nome, matrícula, setor e salário.

Ao lado o nome e o setor, onde desejamos digitar o nome e puxar o setor de cada pessoa.

Para isso, iremos realizar a função PROCV, e iremos buscar o salário, não mais o setor.

Fórmula: =PROCV(G7;B7:E14;4;0)

Para que nosso PROCV fique dinâmico, usaremos a função CORRESP.

Função CORRESP

O valor procurado será o G7, onde está o nome Esther.

Fórmula=CORRESP(G7

A matriz procurada será o intervalo dos nomes. Importante lembrar que a matriz procurada do CORRESP será sempre um intervalo de colunas ou linhas, nunca mais que isso.

Fórmula=CORRESP(G7;B7:B14

Tipo de correspondência: usaremos o zero, correspondência exata.

Fórmula=CORRESP(G7;B7:B14;0)

Resultado:

O número dois é a posição da linha onde está o nome Esther.

Alterando o nome para Renato, o resultado será outro.

Resultado:

Unindo as funções PROCV+CORRESP

O número índice coluna, será substituído pela função CORRESP.

O valor procurado será o nome do setor, referência H6.

Fórmula: =PROCV(G7;B7:E14;CORRESP(H6;0)

A matriz procurada será o intervalo dos títulos da tabela ao lado.

Fórmula: =PROCV(G7;B7:E14;CORRESP(H6;B6:E6;0)

O tipo de correspondência será exata, representada pelo número 0.

Fórmula: =PROCV(G7;B7:E14;CORRESP(H6;B6:E6;0;0)

Ao alterar de setor para matrícula, automaticamente o resultado será alterado.

Para alterar os nomes, usamos a validação de dados, temos post sobre isso, clique aqui

E aí, o que achou do treino de hoje? Comente abaixo:

TAGS:

Opa,

o que você achou dessa aula? Conta pra mim 👇

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

DESAFIO EXCEL 7D

DASHBOARDS PROFISSIONAIS
EM 7 DIAS

OU SEU DINHEIRO DE VOLTA!

Crie sua conta :)

Na próxima tela você irá completar seu cadastro e transformar seu negócio.

Precisa de ajuda?
💬 Precisa de ajuda?
Olá 👋🏽
Como podemos te ajudar?