Falaaa galera, bora para mais um treino?

Dando continuidade em nossa séria da função Se, hoje veremos a combinação da função SE COM SE juntamente com a função PROCV.

Clique aqui para fazer o download da planilha 

Conheça meu novo treinamento de Excel onde você aprende a construir suas próprias planilhas profissionais e automáticas em apenas 7 DIAS!

Iremos verificar a necessidade de reposição de estoque SE o item NÃO ESTIVER OBSOLETO e SE o saldo estiver MENOR OU IGUAL ao estoque mínimo.

Primeiro iremos conferir se o estoque está obsoleto ou não, através da função PROCV.

Fórmula: =PROCV(B8;B8:G16;6;FALSO)

Nosso valor procurado está na célula B8, correspondente ao código do produto. A matriz tabela é todo o intervalo da tabela (B8:G16). O número índice coluna será o 6, pois o texto obsoleto está na sexta coluna da matriz tabela, iniciou-se no código (B8) sendo a primeira coluna. Correspondência exata, assumiu o texto Falso, poderíamos também utilizar o número 0.

IMPORTANTE: Para arrastar a fórmula, precisamos travar nossa matriz tabela.

Fórmula: =PROCV(B8;$B$8:$G$16;6;FALSO)

Feito o teste através do PROCV para saber se o item foi obsoleto ou não, agora vamos utilizar a função SE.

Passo 1: Acrescente a função SE antes da função PROCV.

Clique na barra de fórmula e digite, note que a função PROCV assumirá o teste lógico da função SE.

Fórmula: =SE(PROCV(B8;$B$8:$G$16;6;FALSO)

Passo 2: O PROCV será o teste lógico, comparado ao texto NÃO.

Fórmula: =SE(PROCV(B8;$B$8:$G$16;6;FALSO)=”NÃO”

Passo 3: Usaremos outra função Se.

Fórmula: =SE(PROCV(B8;$B$8:$G$16;6;FALSO)=”NÃO”;SE(F8<=D8

Passo 4: Se o saldo for menor e igual ao estoque mínimo, retornar o texto comprar.

Fórmula: =SE(PROCV(B8;$B$8:$G$16;6;FALSO)=”NÃO”;SE(F8<=D8;“COMPRAR”

Passo 5: O valor se falso, irá retornar a célula vazia.

Fórmula: =SE(PROCV(B8;$B$8:$G$16;6;FALSO)=”NÃO”;SE(F8<=D8;”COMPRAR”;“”

Passo 6: Finalizar a primeira função Se, colocando o valor se falso.

Fórmula:=SE(PROCV(B8;$B$8:$G$16;6;FALSO)=”NÃO”;SE(F8<=D8;”COMPRAR”;””);”OBSOLETO”)

Arraste a fórmula para baixo:

E aí, o que achou do treino de hoje? Comente abaixo:

2 respostas

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.